ebi-pdbe-graph_example_queries
Retrieve example Cypher queries for exploring the PDBe graph database, with each query paired to a question so you can learn how to query protein structure data.
Instructions
Retrieves example Cypher queries for exploring the PDBe (PDBe-KB) graph database.
This tool can be used to get sample queries that demonstrate how to interact with the PDBe graph database using Cypher.
The tool returns a list of example queries, each with an question describing the purpose of the query and the corresponding Cypher query string.
Expected Output Format (text):
Question: Give me all the structures that are released in 2025.
Query:
MATCH (entry:Entry)
WHERE entry.PDB_REV_DATE STARTS WITH '2025'
RETURN entry.ID as PDB_ID,
entry.TITLE as Title,
entry.PDB_REV_DATE as Release_Date,
entry.RESOLUTION as Resolution,
entry.METHOD as Experimental_Method,
entry.STATUS_CODE as Status
ORDER BY entry.PDB_REV_DATE DESC
(Additional example queries follow the same format...)
Input Schema
| Name | Required | Description | Default |
|---|---|---|---|
No arguments | |||