Fetter MCP
OfficialFetter MCP
Fetterは、https://mcp.fetter.io/mcp でリモートのModel Context Protocol(MCP)サーバーを提供し、AIコーディングエージェントにPythonパッケージの脆弱性データへのリアルタイムアクセスを提供します。fetter上に構築されており、PyPIとOSVを照会して、既知のCVE、CVSSスコア、安全なバージョンを明らかにするため、エージェントはコードを書く際に情報に基づいた依存関係の決定を行うことができます。
ツール:
most_recent_not_vulnerable: 既知の脆弱性がないパッケージの最新リリースを見つけるis_vulnerable: 特定の固定バージョンに既知のCVEがあるかどうかを確認するlookup: 任意のパッケージまたは指定子について、利用可能なバージョンとその脆弱性を見つける
インストール
Fetter MCPサーバーはHTTPトランスポートを使用し、ローカルインストールは不要です。リモートURLをMCPクライアントに登録するだけです。
Claude Code
claude mcp add --transport http fetter https://mcp.fetter.io/mcpCodex
codex mcp add fetter --url https://mcp.fetter.io/mcpその他のMCPクライアント
その他のMCP互換クライアントの場合は、HTTPトランスポートを使用して次のリモートサーバーURLを指定します。
https://mcp.fetter.io/mcpRelated MCP server: cve-lookup-mcp
エージェントの使用法
インストール後、Fetter MCPツールはコーディングセッション中にAIエージェントが利用できるようになります。エージェントは依存関係を追加または監査するときにこれらのツールを自動的に呼び出すことができ、プロンプトで明示的にツールを呼び出す必要はありません。
プロンプトの例
"requirements.txt に requests の最新の安全なバージョンを追加して"
"現在の依存関係に既知の脆弱性はありますか?"
"CVE のない pillow の最新バージョンは何ですか?"
"cryptography を固定する前に、42.0.5 が脆弱かどうか確認して"
エージェントはコンテキストに基づいて適切なツールを選択します。
新しいパッケージを追加する場合:
most_recent_not_vulnerableで安全なバージョンを見つける特定の固定バージョンを検証する場合:
is_vulnerableで明確な回答を得る既存の指定子を監査する場合:
lookupで影響を受けるバージョンを確認する
most_recent_not_vulnerable
既知の脆弱性がないパッケージの最新バージョンを見つけます。パッケージ名のみを指定すると、サーバーが最近のリリースから安全なバージョンを検索します。依存関係を最新のクリーンなリリースに固定するときに便利です。
パラメータ
package_name— パッケージ名のみ(バージョン指定子なし)。例:"requests"
リクエスト例
{
"jsonrpc": "2.0",
"method": "tools/call",
"id": 2,
"params": {
"name": "most_recent_not_vulnerable",
"arguments": {
"name": "cryptography"
}
}
}レスポンス例:
{
"jsonrpc": "2.0",
"id": 2,
"result": {
"content": [],
"structuredContent": {
"package": "cryptography",
"version": "46.0.5",
"vulnerabilities": [],
"vulnerable": false
},
"isError": false
}
}is_vulnerable
特定のパッケージバージョンに既知の脆弱性があるかどうかを確認します。正確なバージョン指定子が必要です。脆弱性ID、要約、CVSSスコア、重大度評価、および参照URLを返します。
パラメータ
dep_spec— 正確なバージョン指定子。例:"requests==2.31.0"
リクエスト例
{
"jsonrpc": "2.0",
"method": "tools/call",
"id": 2,
"params": {
"name": "is_vulnerable",
"arguments": {
"name": "requests==2.19.1"
}
}
}レスポンス例:
{
"jsonrpc": "2.0",
"id": 2,
"result": {
"content": [],
"structuredContent": {
"package": "requests",
"version": "2.19.1",
"vulnerabilities": [
{
"cvss_score": 5.3,
"id": "GHSA-9hjg-9r4m-mvj7",
"severity": "(Medium):",
"summary": "Requests vulnerable to .netrc credentials leak via malicious URLs",
"url": "https://osv.dev/vulnerability/GHSA-9hjg-9r4m-mvj7"
},
{
"cvss_score": 5.6,
"id": "GHSA-9wx4-h78v-vm56",
"severity": "(Medium):",
"summary": "Requests Session object does not verify requests after making first request with verify=False",
"url": "https://osv.dev/vulnerability/GHSA-9wx4-h78v-vm56"
},
{
"cvss_score": 6.1,
"id": "GHSA-j8r2-6x86-q33q",
"severity": "(Medium):",
"summary": "Unintended leak of Proxy-Authorization header in requests",
"url": "https://osv.dev/vulnerability/GHSA-j8r2-6x86-q33q"
},
{
"cvss_score": 7.5,
"id": "GHSA-x84v-xcm2-53pg",
"severity": "(High):",
"summary": "Insufficiently Protected Credentials in Requests",
"url": "https://osv.dev/vulnerability/GHSA-x84v-xcm2-53pg"
},
{
"cvss_score": null,
"id": "PYSEC-2018-28",
"severity": null,
"summary": "",
"url": "https://osv.dev/vulnerability/PYSEC-2018-28"
},
{
"cvss_score": null,
"id": "PYSEC-2023-74",
"severity": null,
"summary": "",
"url": "https://osv.dev/vulnerability/PYSEC-2023-74"
}
],
"vulnerable": true
},
"isError": false
}
}lookup
パッケージ名とオプションのバージョン指定子でパッケージを検索し、利用可能なバージョンと既知の脆弱性の有無を確認します。"requests"、"numpy>=2.0"、"flask==3.0.0" などの指定子をサポートします。
パラメータ
dep_specs— パッケージ名またはバージョン指定子cvss_threshold— このCVSSスコア(0〜10)以上の脆弱性にフィルタリングするmax_observed_score— 個々の脆弱性すべてではなく、バージョンごとの最高CVSSスコアのみを返すcount— チェックする最近のバージョン数を制限するretain_passing— 既知の脆弱性がないバージョンを結果に含める
リクエスト例
{
"jsonrpc": "2.0",
"method": "tools/call",
"id": 2,
"params": {
"name": "lookup",
"arguments": {
"name": "requests>=2.32.0",
"retain_passing": true
}
}
}レスポンス例:
{
"jsonrpc": "2.0",
"id": 2,
"result": {
"content": [],
"structuredContent": {
"package": "requests",
"versions": [
{
"version": "2.32.0",
"vulnerabilities": [
{
"cvss_score": 5.3,
"id": "GHSA-9hjg-9r4m-mvj7",
"severity": "(Medium):",
"summary": "Requests vulnerable to .netrc credentials leak via malicious URLs",
"url": "https://osv.dev/vulnerability/GHSA-9hjg-9r4m-mvj7"
}
],
"vulnerable": true
},
{
"version": "2.32.1",
"vulnerabilities": [
{
"cvss_score": 5.3,
"id": "GHSA-9hjg-9r4m-mvj7",
"severity": "(Medium):",
"summary": "Requests vulnerable to .netrc credentials leak via malicious URLs",
"url": "https://osv.dev/vulnerability/GHSA-9hjg-9r4m-mvj7"
}
],
"vulnerable": true
},
{
"version": "2.32.2",
"vulnerabilities": [
{
"cvss_score": 5.3,
"id": "GHSA-9hjg-9r4m-mvj7",
"severity": "(Medium):",
"summary": "Requests vulnerable to .netrc credentials leak via malicious URLs",
"url": "https://osv.dev/vulnerability/GHSA-9hjg-9r4m-mvj7"
}
],
"vulnerable": true
},
{
"version": "2.32.3",
"vulnerabilities": [
{
"cvss_score": 5.3,
"id": "GHSA-9hjg-9r4m-mvj7",
"severity": "(Medium):",
"summary": "Requests vulnerable to .netrc credentials leak via malicious URLs",
"url": "https://osv.dev/vulnerability/GHSA-9hjg-9r4m-mvj7"
}
],
"vulnerable": true
},
{
"version": "2.32.4",
"vulnerabilities": [],
"vulnerable": false
},
{
"version": "2.32.5",
"vulnerabilities": [],
"vulnerable": false
}
]
},
"isError": false
}
}This server cannot be deployed
Maintenance
Related MCP Connectors
CVE lookups (NVD) and dependency-manifest audits (OSV) for AI agents. No API keys.
CVE lookups (NVD) and dependency-manifest audits (OSV) for AI agents. No API keys.
Check packages for CVEs, slopsquatting, and CISA KEV before your AI agent installs them.
Live npm and UNPKG data for AI agents: resolution, audits, import maps, malware/CVE checks.
141
Related MCP Servers
- AlicenseAqualityAmaintenanceDependency intelligence for AI agents. CVE scanning, health checks, upgrade planning.9412 npm2Apache 2.0
- AlicenseAqualityDmaintenanceProvides live CVE data from NVD and EPSS without API key, enabling AI assistants to look up CVSS scores, search vulnerabilities, and check product CVEs.3MIT
- AlicenseNot gradedqualityDmaintenanceProvides CVE lookup, search, and exploit intelligence from public vulnerability sources (NVD, CISA KEV, EPSS) for AI agents to produce remediation guidance without consuming LLM tokens for data fetching.1MIT
- AlicenseAqualityBmaintenanceVulnerability intelligence for AI agents that enables CVE lookup, package vulnerability checks, and dependency auditing without API keys.5MIT